BAB I
PENDAHULUAN

1.1 Latar Belakang
Pengunaan teknologi jaringan komputer sebagai media komunikasi data sampai saat ini semakin berkembang. Kebutuhan atas penggunaan bersama resources yang ada dalam jaringan baik software maupun hardware telah mengakibatkan timbulnya berbagai pengembangan teknologi jaringan itu sendiri. Sejalan dengan tingginya penguna jaringan yang berharap maksimal terhadap efisiensi kerja bahkan sampai tingkat kemanan jaringan komputer itu sendiri.
Latar belakang itulah yang membuat berbagai pihak yang bergelut dibidang jaringan berusaha menyempurnakan jaringan itu sendiri. Dengan memanfaatkan berbagai tekhnik khususnya teknik subnetting dan penggunaan hardware yang lebih baik (antara lain switch) maka muncullah konsep Virtual Local Area Network (VLAN) yang diharapkan dapat memberikan hasil yang lebih baik dibanding Local area Network (LAN).

1.2 Tujuan
Menerapkan konsep Virtual Local Area Network (VLAN) sebagai konsep jaringan yang diharapkan dapat memberikan hasil yang lebih baik dibandingkan Local Area Network.

BAB II
DASAR TEORI

2.1 Pengertian

Sebuah Local Area Network (LAN) pada dasarnya diartikan sebagai sebuat network dari kumpulan computer yang berada pada lokasi yang sama. Sebuah LAN diartikan sebagai single broadcast domain, artinya ada sebuah broadcast informasi dari seorang user dalam LAN, broadcast akan diterima oleh setiap user lain dalam LAN tersebut.Broadcast yang keluar dari LAN bisa difilter dengan router. Susunan dari broadcast domain tergantung juga dari jenis koneksi fisik perangkat networknya. Virtual Local Area Network (VLAN) dikembangkan sebagai pilihan alternatif untuk mengurangi broadcast traffic.
Sebuah Virtual LAN merupakan fungsi logik dari sebuah switch. Fungsi logik ini mampu membagi jaringan LAN ke dalam beberapa jaringan virtual. Jaringan virtual ini tersambung ke dalam perangkat fisik yang sama. Implementasi VLAN dalam jaringan memudahkan seorang administrator dalam membagi secara logik group-group workstation secara fungsional dan tidak dibatasi oleh lokasi.
Berikut ini diberikan beberapa terminologi di dalam VLAN.
a. VLAN Data
VLAN Data adalah VLAN yang dikonfigurasi hanya untuk membawa data-data yang digunakan oleh user. Dipisahkan dengan lalu lintas data suara atau pun manajemen switch. Seringkali disebut dengan VLAN pengguna, User VLAN.
b. VLAN Default
Semua port switch pada awalnya menjadi anggota VLAN Default. VLAN Default untuk Switch Cisco adalah VLAN 1. VLAN 1 tidak dapat diberi nama dan tidak dapat dihapus.
c. Native VLAN
Native VLAN dikeluarkan untuk port trunking 802.1Q. port trunking 802.1Q mendukung lalu lintas jaringan yang datang dari banyak VLAN (tagged traffic) sama baiknya dengan yang datang dari sebuah VLAN (untagged traffic). Port trunking 802.1Q menempatkan untagged traffic pada Native VLAN.
d. VLAN Manajemen
VLAN Manajemen adalah VLAN yang dikonfigurasi untuk memanajemen switch. VLAN 1 akan bekerja sebagai Management VLAN jika kita tidak mendefinisikan VLAN khusus sebagai VLAN Manajemen. Kita dapat memberi IP address dan subnet mask pada VLAN Manajemen, sehingga switch dapat dikelola melalui HTTP, Telnet, SSH, atau SNMP.
e. VLAN Voice
VLAN yang dapat mendukung Voice over IP (VoIP). VLAN yang dikhusukan untuk komunikasi data suara.
2.2 Tipe-tipe VLAN
Terdapat 3 tipe VLAN dalam konfigurasi, yaitu:
a. Static VLAN – port switch dikonfigurasi secara manual.
b. Dynamic VLAN – Mode ini digunakan secara luas di jaringan skala besar. Keanggotaan port Dynamic VLAN dibuat dengan menggunakan server khusu yang disebut VLAN Membership Policy Server (VMPS). Dengan menggunakan VMPS, kita dapat menandai port switch dengan VLAN? secara dinamis berdasar pada MAC Address sumber yang terhubung dengan port.
c. Voice VLAN – port dikonfigurasi dalam mode voice sehingga dapat mendukung IP phone yang terhubung.
Konfigurasi:
2.3 Keanggotaan VLAN
Keanggotaan dalam suatu VLAN dapat di klasifikasikan berdasarkan port yang di gunakan , MAC address, tipe protokol
1. Berdasarkan Port
Keanggotaan pada suatu VLAN dapat di dasarkan pada port yang di gunakan oleh VLAN tersebut. Sebagai contoh, pada bridge/switch dengan 6 port, port 1 dan 3 merupakan VLAN 1 sedang port 2 dan 4 dimiliki oleh VLAN 2.
Kelemahannya adalah user tidak bisa untuk berpindah pindah, apabila harus berpindah maka Network administrator harus mengkonfigurasikan ulang.

Port 1 2 3 4 5 6
VLAN 1 2 1 2 .. ..
Kelemahannya adalah user tidak bisa untuk berpindah pindah, apabila harus berpindah maka Network administrator harus mengkonfigurasikan ulang.
2. Berdasarkan MAC Address
Keanggotaan suatu VLAN didasarkan pada MAC address dari setiap workstation /komputer yang dimiliki oleh user. Switch mendeteksi/mencatat semua MAC address yang dimiliki oleh setiap Virtual LAN. MAC address merupakan suatu bagian yang dimiliki oleh NIC (Network Interface Card) di setiap workstation.
Kelebihannya apabila user berpindah pindah maka dia akan tetap terkonfigurasi sebagai anggota dari VLAN tersebut.Sedangkan kekurangannya bahwa setiap mesin harus di konfigurasikan secara manual , dan untuk jaringan yang memiliki ratusan workstation maka tipe ini kurang efissien untuk dilakukan.

Tabel MAC address dan VLAN
MAC address 02004C4F4F50 02004C4F4F51 02004C4F4F53 02004C4F4F56
VLAN 1 2 1 2

3. Berdasarkan tipe protokol yang digunakan
Keanggotaan VLAN juga bisa berdasarkan protocol yang digunakan, lihat table.

Tabel protokol dan VLAN
Protokol IP IPX IP IPX
VLAN 1 2 1 2

4. Berdasarkan alamat subnet IP
Subnet IP address pada suatu jaringan juga dapat digunakan untuk mengklasifikasi suatu VLAN

Tabel subnet VLAN
IP subnet 22.3.24 46.20.45
VLAN 1 2

Konfigurasi ini tidak berhubungan dengan Routing pada jaringan dan juga tidak mempermasalahkan funggsi router.IP address digunakan untuk memetakan keanggotaan VLAN.Keuntungannya seorang user tidak perlu mengkonfigurasikan ulang alamatnya di jaringan apabila berpindah tempat, hanya saja karena bekerja di layer yang lebih tinggi maka akan sedikit lebih lambat untuk meneruskan paket di banding menggunakan MAC addresses.

5. Berdasarkan aplikasi atau kombinasi lain
Sangat dimungkinkan untuk menentukan suatu VLAN berdasarkan aplikasi yang dijalankan, atau kombinasi dari semua tipe di atas untuk diterapkan pada suatu jaringan. Misalkan: aplikasi FTP (file transfer protocol) hanya bias digunakan oleh VLAN 1 dan Telnet hanya bisa digunakan pada VLAN 2.
2.4 Bagaimana VLAN bekerja
Dalam tradisioanl LAN, workstation masing-masing terhubung dengan workstation yang lain dalam sebuah hub. Perangkat ini akan menyebarkan semua lalu lintas data di seluruh network. Jika ada dua user yang mencoba mengirim informasi pada waktu yang sama, sebuah tabrakan (collision) akan terjadi dan semua pengiriman data akan hilang. Jika tabrakan (collision) telah terjadi, pengiriman data akan dilanjutkan disebar di seluruh network oleh hub. Informasi data asal akan terus mengirim sampai dengan collision hilang. Dengan demikian akan banyak membuang waktu dan resource (sumber daya).
Untuk mengatasi collision di sebuah network, maka digunakanlah sebuah bridge atau sebuah switch. Perangkat ini tidak akan mem-forward collision, tapi bisa melewatkan broadcast (ke setiap user di network) dan multicast. Dan sebuah router digunakan untuk mencegah broadcast dan multicast dari lalulintas data network.
VLAN diklasifikasikan berdasarkan metode (tipe) yang digunakan untuk mengklasifikasikannya, baik menggunakan port, MAC addresses dsb. Semua informasi yang mengandung penandaan/pengalamatan suatu vlan (tagging) di simpan dalam suatu database (tabel), jika penandaannya berdasarkan port yang digunakan maka database harus mengindikasikan port-port yang digunakan oleh VLAN. Untuk mengaturnya maka biasanya digunakan switch/bridge yang manageable atau yang bisa di atur. Switch/bridge inilah yang bertanggung jawab menyimpan semua informasi dan konfigurasi suatu VLAN dan dipastikan semua switch/bridge memiliki informasi yang sama. Switch akan menentukan kemana data-data akan diteruskan dan sebagainya.atau dapat pula digunakan suatu software pengalamatan (bridging software) yang berfungsi mencatat/menandai suatu VLAN beserta workstation yang didalamnya.untuk menghubungkan antar VLAN dibutuhkan router.

Beberapa keuntungan penggunaan VLAN antara lain:
3 Security – keamanan data dari setiap divisi dapat dibuat tersendiri, karena segmennya bisa dipisah secarfa logika. Lalu lintas data dibatasi segmennya.
4 Cost reduction – penghematan dari penggunaan bandwidth yang ada dan dari upgrade perluasan network yang bisa jadi mahal.
5 Higher performance – pembagian jaringan layer 2 ke dalam beberapa kelompok broadcast domain yang lebih kecil, yang tentunya akan mengurangi lalu lintas packet yang tidak dibutuhkan dalam jaringan.
6 Broadcast storm mitigation – pembagian jaringan ke dalam VLAN-VLAN akan mengurangi banyaknya device yang berpartisipasi dalam pembuatan broadcast storm. Hal ini terjadinya karena adanya pembatasan broadcast domain.
7 Improved IT staff efficiency – VLAN memudahkan manajemen jaringan karena pengguna yang membutuhkan sumber daya yang dibutuhkan berbagi dalam segmen yang sama.
8 Simpler project or application management – VLAN menggabungkan para pengguna jaringan dan peralatan jaringan untuk mendukung perusahaan dan menangani permasalahan kondisi geografis.

BAB III
KONFIGURASI VLAN

3.1 Study kasus
Disuatu Universitas Politeknik Telkom mempunyai 3 Tingkat, dipoliteknik tersebut mempunyai beberapa Department dan UKM diantaranya ( Administrasi, Marketing, BEM, IPTEK, BAA dan Kreatif ), untuk lebih jelas lihat table dibawah ini :
Departement/UKM Banyak User Lantai 1 Lantai 2 Lantai 3
Administrasi 10 User 5 User 5 User –
Marketing 10 User 5 User 5 User –
BEM 8 User – 4 User 4 User
IPTEK 5 User – 5 User –
BAA 3 User – – 3 User
Tabel 1. Rincian User Pada setiap Departement

Dengan Virtual LAN ( VLAN ) yang akan dibuat pada setiap departement adalah seperti terlihat pada table dibawah ini :
Create VLAN Departement/UKM
VLAN 10 Administrasi
VLAN 20 Marketing
VLAN 30 BEM
VLAN 40 IPTEK
VLAN 50 BAA
Tabel 2. Create VLAN

Setelah itu kita bisa menentukan IP Address yang akan dipasang pada setiap VLAN dengan rincian IP Address seperti pada table dibawah ini :
VLAN NETWORK GATEWAY
VLAN 10 192.168.1.0/24 192.168.1.1
VLAN 20 192.168.2.0/24 192.168.2.1
VLAN 30 192.168.3.0/24 192.168.3.1
VLAN 40 192.168.4.0/24 192.168.4.1
VLAN 50 192.168.5.0/24 192.168.5.1
Tabel 3. Standarisari IP Address

Untuk membuat jaringan VLAN dibutuhkan Hardware untuk mendukung dalam pemnuatan jaringan VLAN, Hardware yang dibutuhkan adalah sebagai berikut :

Hardware Model Sfesifikasi
Router 2621 Fast Ethernet 2
Wan Options 1 serial, 2 serial, 1 bri
Switch 2950 Fast Ethernet 12
Komputer PC Ethernet 1
Tabel 4. Kebutuhan Hardware VLAN

Dengan kebutuhan seperti diatas maka kita membutuhkan 3 switch dan 1 router, dengan topologi jaringan VLAN seperti dibawah ini :

Gambar 1. Topologi VLAN [gambar menyusul Gan]

3.2 Langkah-langkah konfigurasi jaringan VLAN

a) Switch
Pada Switch yang harus kita lakukan adalah sbb:
1. Create VLAN
2. Set port Trunk + Assign port utk trunk + set encapsulationnya
3. Assign port untuk setiap VLAN
4. Set port Access
Standarisasi nama PC client V_1.2.3
V = VLAN
1 = VLAN ID
2 = Lantai gedung
3 = Urutan di setiap lantai dan VLAN ID

b) Router
Pada Router yang harus kita lakukan adalah sbb:
1. Buat Sub-interface sebanyak VLAN yg telah kita create
2. Set Gateway di setiap Sub-Interface
3. Set Encapsulation sesuai dengan encapsulation yg dipakai di switch

3.3 Konfigurasi VLAN
a) Konfogurasi pada switch katalis
#Switch_Lt1
Switch>enable
Switch#vlan database
Switch(vlan)#vlan 10 name administrasi
Switch(vlan)#vlan 20 name marketing
Switch(vlan)#exit
Switch#configure terminal
Switch(config)#interface fastethernet 0/12
Switch(config-if)#switchport mode trunk
Switch(config-if)#switchport trunk encapsulation dot1q
Switch(config-if)#exit
Switch(config)#interface fastethernet 0/1
Switch(config-if)#switchport mode access
Switch(config-if)#switchport access vlan 10
Switch(config-if)#exit
Switch(config)#interface fastethernet 0/2
Switch(config-if)#switchport mode access
Switch(config-if)#switchport access vlan 20
Switch(config-if)#exit
Switch(config)#exit
Switch#copy running-config startup-config

#Switch_Lt2
Switch>enable
Switch#vlan database
Switch(vlan)#vlan 10 name administrasi
Switch(vlan)#vlan 20 name marketing
Switch(vlan)#vlan 30 name bem
Switch(vlan)#vlan 40 name iptek
Switch(vlan)#exit
Switch#configure terminal
Switch(config)#interface fastethernet 0/12
Switch(config-if)#switchport mode trunk
Switch(config-if)#switchport trunk encapsulation dot1q
Switch(config-if)#exit
Switch(config)#interface fastethernet 0/11
Switch(config-if)#switchport mode trunk
Switch(config-if)#switchport trunk encapsulation dot1q
Switch(config-if)#exit
Switch(config)#interface fastethernet 0/10
Switch(config-if)#switchport mode trunk
Switch(config-if)#switchport trunk encapsulation dot1q
Switch(config-if)#exit
Switch(config)#interface fastethernet 0/1
Switch(config-if)#switchport mode access
Switch(config-if)#switchport access vlan 10
Switch(config-if)#exit
Switch(config)#interface fastethernet 0/2
Switch(config-if)#switchport mode access
Switch(config-if)#switchport access vlan 20
Switch(config-if)#exit
Switch(config)#interface fastethernet 0/3
Switch(config-if)#switchport mode access
Switch(config-if)#switchport access vlan 30
Switch(config-if)#exit
Switch(config)#interface fastethernet 0/4
Switch(config-if)#switchport mode access
Switch(config-if)#switchport access vlan 40
Switch(config-if)#exit
Switch(config)#exit
Switch#copy running-config startup-config

#Switch_Lt3
Switch>en
Switch#vlan database
Switch(vlan)#vlan 30 name bem
Switch(vlan)#vlan 50 name baa
Switch(vlan)#exit
Switch#configure terminal
Switch(config)#interface fastethernet 0/11
Switch(config-if)#switchport mode trunk
Switch(config-if)#switchport trunk encapsulation dot1q
Switch(config-if)#exit
Switch(config)#interface fastethernet 0/1
Switch(config-if)#switchport mode access
Switch(config-if)#switchport access vlan 30
Switch(config-if)#exit
Switch(config)#interface fastethernet 0/2
Switch(config-if)#switchport mode access
Switch(config-if)#switchport access vlan 50
Switch(config-if)#exit
Switch(config)#exit
Switch#copy running-config startup-config

Verify pada switch :
Switch# show vlan
Switch# show vlan [number]
Switch# show running-config

#Rrt_VLAN
Router>enable
Router#configure terminal
Router(config)#interface fastethernet 0/0
Router(config-if)#no shutdown
Router(config-if)#exit
Router#configure terminal
Router(config)#interface fastethernet 0/0.10
Router(config-subif)#encapsulation dot1q 10
Router(config-subif)#ip address 192.168.1.1 255.255.255.0
Router(config-subif)#exit
Router(config)#interface fastethernet 0/0.20
Router(config-subif)#encapsulation dot1q 20
Router(config-subif)#ip address 192.168.2.1 255.255.255.0
Router(config-subif)#exit
Router(config)#interface fastethernet 0/0.30
Router(config-subif)#encapsulation dot1q 30
Router(config-subif)#ip address 192.168.3.1 255.255.255.0
Router(config-subif)#exit
Router(config)#interface fastethernet 0/0.40
Router(config-subif)#encapsulation dot1q 40
Router(config-subif)#ip address 192.168.4.1 255.255.255.0
Router(config-subif)#exit
Router(config)#interface fastethernet 0/0.50
Router(config-subif)#encapsulation dot1q 50
Router(config-subif)#ip address 192.168.5.1 255.255.255.0
Router(config-subif)#exit
Router(config)#exit
Router#copy running-config startup-config

Verify pada Router :
Router# show ip route
Router# show running-config

#Penjelasan command pada switch :

Switch(config)# interface fastethernet 0/2
Switch(config-if)# switchport mode access
Switch(config-if)# switchport access vlan [VLAN ID]

Maksud dari 3 perintah diatas adalah Meng-assignkan port fastethernet 0/2 menjadi milik [VLANID] dan membuat port tersebut mempunyai mode access. That’s means.. port tersebut hanya dapat membawa [VLAN ID]nya saja dan ini penting untuk di terapkan di setiap port yg menuju ke PC Client.

Switch(config)# interface fastethernet 0/11
Switch(config-if)# switchport mode trunk
Switch(config-if)# switchport trunk encapsulation dot1q

Maksud dari 3 perintah diatas adalah Meng-assignkan port fastethernet 0/11 mempunyai encapsulation dot1q dan menjadikan port tersebut menjadi trunk. Trunk means.. pada link port tersebut dia yg bekerja membawa multiple [VLAN ID] dalam satu link. Oleh karena itu Kita bisa berkomunikasi antar VLAN.. dikarenakan ada port yang dijadikan trunk.
Penjelasan command pada router :

Rtr_VLAN(config)# interface fastethernet 0/0.10
Rtr_VLAN(config-subif)# encapsulation dot1q 10
Rtr_VLAN(config)# ip address 192.168.1.1 255.255.255.0

Pada 3 baris perintah diatas kita membuat sub-interface dimana “fastethernet 0/0″ ini adalah parent dari interface yg kita pakai dan “fastethernet 0/0.10″ ini adalah child dari dari “fastethernet 0/0″. pada “.10″ ini sebenarnya terserah kita ingin menggunakan berapa saja, asalkan berupa digit. Saya menggunakan “10″ karena pada sub-interface yang saya pasang adalah khusus untuk VLAN ID 10, sehingga utk kedepannya bila terjadi error atau maintenance akan mempermudah kita dalam men-solve the problem. Lalu saya memetakan pada VLAN ID 10 itu adalah Networknya 192.168.1.0/24 atau Network 192.168.1.0 Netmasknya 255.255.255.0 dan Gateway 192.168.1.1. Inget!!! Gateway harus diletakkan di Router, karena Routerlah yg bekerja di Layer 3 dari OSI Layer. Klo Switch manageable lebih banyak bekerja di Layer 2 dari OSI Layer.

#Scrint server

Gambar 2. Switch_Lt1 [gambar menyusul Gan]

Gambar 3.Switch_lt3 [gambar menyusul Gan]

Gambar 4.Switch_Lt2 [gambar menyusul Gan]

Gambar 5. Switch_Lt3 [gambar menyusul Gan]

BAB IV
PENUTUP

4.I. KESIMPULAN

Jadi dengan menggunakan konsep jaringan VLAN, jaringan dapat dibagi-bagi berdasarkan grup hal ini akan menjadikan jaringan bisa lebih aman dan bisa termanage dengan mudah oleh seorang administrator jaringan. Hal ini akan mempermudah bagi pekerjaan seorang administrator jaringan dalam melakukan pengecekan dan monitoring clientnya.

4.2 SARAN
Sebaiknya untuk jaringan yang ada pada perkantoran, hendaknya menerapkan jaringan VLAN, hal ini untuk memudahkan dalam monitoring terhadap client.

Iklan